BigQuery Error: Billing Has Not Been Enabled for This Project
This article explains how to resolve a BigQuery billing error that can occur when attempting to run your data exports.
Error

When attempting to run a BigQuery export of your Power My Analytics report, you may see the following error in the View Logs panel:
"Billing has not been enabled for this project. Enable billing at https://console.cloud.google.com/billing"
Causes
Data imports into BigQuery require a paid plan with active billing enabled. Free BigQuery plans do not support the data import functionality needed for Power My Analytics exports.
This error typically occurs when:
- You're using a free BigQuery version. Data imports into BigQuery, such as those provided by PMA's export feature, are not supported by BigQuery's free plan.
- You're using a paid version of BigQuery that does not currently support the required data imports.
Solution
Enable billing for your BigQuery project. This requires your project to be linked to a valid, active Cloud Billing account.
- Follow Google Cloud's support instructions to identify the Cloud Billing account linked to your BigQuery project.
- If there is no Cloud Billing account linked to your project, this page will read "This project has no billing account".
- To enable billing on your BigQuery project, follow the Google Cloud support instructions to enable billing for an existing project.
Once your BigQuery project is linked to a Cloud Billing account and billing is enabled, it may take up to 24 hours to become active. Please wait 24 hours after activating billing in your project before running your BigQuery export in PMA.
Next, run your export again and verify that it ran successfully:
- Return to the Exports > BigQuery section of your PMA hub. Find your export and click the Run Export Now button.
- Open the View Logs panel for the export. The logs should show that the export ran successfully.
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