Connector Error: Please click "REFRESH AUTHENTICATION" and reauthenticate with Power My Analytics

Connector Error: Please click "REFRESH AUTHENTICATION" and reauthenticate with Power My Analytics

Info
When creating reports in Looker Studio using Power My Analytics data sources, you may encounter the "Please click 'REFRESH AUTHENTICATION'" community connector error. This guide will walk you through understanding and resolving the error, ensuring seamless access to your data.

Error



"Please click 'REFRESH AUTHENTICATION' and reauthenticate with Power My Analytics"
  • Data Sources Affected: Any
  • Data Destination Affected: Looker Studio
  • Occurs: When attempting to create a report using a Power My Analytics data source in Looker Studio

Causes

This error can occur due to several reasons:

  1. Recent changes to your account password
  2. The person who connected to the data source no longer has access 
  3. Inadvertent loss of one of the API tokens (very rare)
  4. The permissions for our App were recently changed
  5. Glitch during the initial data source connection process

Solution

Follow these steps to resolve the error:

  1. Access Power My Analytics Hub
  2. Disconnect the Affected Source
    • Locate the data source experiencing the error
    • Click the red "exit" icon to disconnect the source



    • Note: This action will not impact your existing reports
  3. Reconnect the Data Source
  4. Retry Connection in Looker Studio
    • Return to Looker Studio
    • Attempt to create your report using the reconnected data source

Persistent Errors with Google Data Sources 

  1. Data Sources Affected: Google Ads, Google Analytics 4, Google Business Profile, Google Search Console, YouTube Analytics
If you are attempting to reauthenticate a Google data source but the above error continues to appear after reauthenticating, please follow the instructions in our article Google Account Disconnects When Using Google Workspace.
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