Error: "This action is not supported while logged into multiple accounts" or "accounts.google.com refused the connection"

Error: "This action is not supported while logged into multiple accounts" or "accounts.google.com refused the connection"

This article will assist you with the following errors:
  1. "Error: This action is not supported while logged into multiple accounts in the same domain or multiple consumer accounts. Please log out and try again." in Looker Studio.
  2. "accounts.google.com refused the connection" in Google Sheets.

Looker Studio: This action is not supported

Cause

Connecting to Looker Studio requires only one Google account to be logged in at any given time when trying to connect a data source.

Solution

Log out of all Google accounts in your browser except the Google account you will use to connect to Looker Studio.


Google Sheets: accounts.google.com refused the connection

Cause

When you're signed into multiple Google accounts in the same browser session, Google's authentication system can become confused. This issue affects multiple Power My Analytics features that integrate with Google services, including Google Sheets and Looker Studio.

Solutions

  1. Option 1: Sign out of each Google account except the one you need for Power My Analytics, then return to PMA and attempt to load the spreadsheet again.
  2. Option 2: Open a new incognito/private browsing window in your browser and sign in to only the Google account you want to use with Power My Analytics, then try to reload your spreadsheet.
Notes
Note: When using incognito/private browsing mode, you'll need to enable cookies for the Google authentication to work properly. Most browsers block cookies in private browsing by default.

Additional Resources

  1. Google Sheets Error: "Exception: Service Timed Out: Spreadsheets" or "Service Spreadsheets timed out when accessing document"


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