Google Account Disconnects When Using Google Workspace

Google Account Disconnects When Using Google Workspace

This article will assist you with the following errors:

In Looker Studio: Please click "REFRESH AUTHENTICATION" and reauthenticate with Power My Analytics/Authorization Error - Access Token Expired, please disconnect and reconnect



In Google Sheets: Authorization Error - Access Token Expired, please disconnect and reconnect



In Data Explorer: Data source error: Google account [account name] has disconnected



In Sources: The account is disconnected/Access token failed to refresh! If this repeats, please re-authenticate your account.





In BigQuery exports: Error: Unable to get account Authorization Error - Access Token Expired, please disconnect and reconnect



Cause

A connected Google data source may repeatedly disconnect with the above error message. This can occur when using a Google Workspace organizational account. Because of changes by Google in their use of organizational access credentials, you will need to add Power My Analytics in the Google admin console as a trusted app.

Solution

Open the Google admin console. Navigate to Security > Access and data control.



Go to Google Cloud session control.



Check Exempt trusted apps under Reauthentication Policy



Click on Apps Access Control.



Select the Power My Analytics app with the following ID:
606653648723-k566fvtsbo079dgdtctekhuih0eiccnn.apps.googleusercontent.com


Click Change access.



Select your organization and click Next.



Then choose Trusted and click next.



Click Change access.



Close Apps Access Control to return to Google Cloud Session Control. Click Save.

Finally, return to your Power My Analytics hub and go to the Sources section. Click the Re-connect account icon next to your Google data source to reconnect the source.



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