This article will address the following error:
Authorization Error - (#10) Application does not have permission for this action.
Cause
The Instagram Insights account in use does not have the appropriate permissions to connect via Power My Analytics.
Solution
Check Permissions
Reconnect Your Account
Reset Business Integration Settings in Facebook
Reconnect your Instagram account with Power My Analytics in your destination or Hub.
Check Whether Your Page is Active
A Facebook page that has been unpublished or deactivated for any reason will need to be reactivated to create a successful connection. If the page does not appear in the Pages menu, it may have been unpublished.
Reconnect Facebook and Instagram
While logged in to the Facebook account attached to the Instagram account, click Pages in the left menu.
Select your page. Click on your profile picture and select Settings and Privacy from the menu that appears.
Click Settings.
Click Disconnect Account.
When you are ready, connect the account again.
Enable Two-Factor Authentication
If the Facebook Page to which the Instagram account is linked has two-factor authentication, then your Facebook profile must also have two-factor authentication for a successful connection.