Community Connector Error: Authorization Error - (#10) Application Does Not Have Permission for This Action

Community Connector Error: Authorization Error - (#10) Application Does Not Have Permission for This Action

This article will address the following error:

Authorization Error - (#10) Application does not have permission for this action.



Cause

The Instagram Insights account in use does not have the appropriate permissions to connect via Power My Analytics.

Solution

Check Permissions

For a successful connection, an Instagram Business or Creator account is required. The account must use Facebook authentication and not have age or other restrictions applied. The account must be linked to an active Facebook Page.

Reconnect Your Account


Reset Business Integration Settings in Facebook

Log in to the Facebook account associated with the Instagram account that is receiving the error. Go to your Business Integrations page. Find Power My Analytics and click Remove.



Reconnect your Instagram account with Power My Analytics in your destination or Hub.



Check Whether Your Page is Active

A Facebook page that has been unpublished or deactivated for any reason will need to be reactivated to create a successful connection. If the page does not appear in the Pages menu, it may have been unpublished.

Reconnect Facebook and Instagram

While logged in to the Facebook account attached to the Instagram account, click Pages in the left menu. 



Select your page. Click on your profile picture and select Settings and Privacy from the menu that appears.



Click Settings.





Click Disconnect Account.



When you are ready, connect the account again.



Enable Two-Factor Authentication

If the Facebook Page to which the Instagram account is linked has two-factor authentication, then your Facebook profile must also have two-factor authentication for a successful connection.

You can enable two-factor authentication in the Security and Login section of your account settings.



    Still having issues?
    Send us a ticket and we will get back to you.
      • Related Articles

      • Error Connecting to Instagram Media Insights

        Instagram requires specific permissions to be enabled in Facebook. This article will show you what you need to know to get your Instagram account connected. This article will assist you with the following error: Causes and Solutions Incompatible ...
      • Community Connector Error: This Instagram Account Is Not Connected to a Facebook Page

        This article will help to resolve the following issue: Community Connector Error PMA Error: This Instagram Account Is Not Connected to a Facebook Page Cause Usually, the Instagram account has not yet been connected to a Facebook Page. Sometimes, it ...
      • Facebook/Instagram Connector Authorization Error

        This article will assist you with the following error: Authorization Error - Error validating access token: The session has been invalidated because the user changed their password or Facebook has changed the session for security reasons. Solution: ...
      • Troubleshooting Instagram

        Most of the difficulties our customers have with Instagram are easy to solve independently without the need to wait for a support ticket reply. This article will help you find everything you need. Instagram Ads All the latest about Instagram Ads' API ...
      • Instagram Insights Data Connector User Guide

        Our Instagram Insights connector provides a wide range of important data that can make reporting easy. This article will tell you everything that you need to know about how to get the most out of your Instagram Insights reports. Available Data Key ...