Microsoft Ads Error: Please Use Another Email Address

Microsoft Ads Error: Please Use Another Email Address

This article will help with the following error:

Error: Please use another email address

Cause

Microsoft Ads is unable to verify your email address through Azure Active Directory. Microsoft Ads has returned error 123: WorkIdentityNotAvailable.

Solution

If you are using a personal email address, attempt to verify with a work email address. If you are using a work email address, attempt to verify with a personal address.

    Still having issues?
    Send us a ticket and we will get back to you.
      • Related Articles

      • Microsoft Ads Error: Your IT Department Must Enable Access

        This article will help with the following error: Microsoft Ads Error: Your IT department must enable access Cause Microsoft Ads requires app-only permissions. Only a tenant administrator can grant access to https://ads.microsoft.com. Without these ...
      • Troubleshooting Microsoft Ads

        Most of the problems that customers have with Microsoft Ads occur at the time they connect in their Hub. This article will give you everything you need to know to troubleshoot problems with your Microsoft Ads connector. Are you getting errors when ...
      • How to Add Another Email Address to Your Hub

        Plans other than Enterprise only allow a limited number of users in your hub. However, you may still want to add another email address to receive bills and other communication about your PMA subscription. If you do not have an Enterprise plan, your ...
      • Change Hub Owner's Email Address

        This article will help you when you need to change the email address associated with your Hub because you no longer use the old email address or have lost access. If you can still access the old email account: 1. Add the new email address as a team ...
      • Amazon Ads Error: Invalid Scope

        This article will address the following error: "Invalid Scope" while connecting to Amazon Ads. Cause During the process of assigning API access to your LwA Application, the proper scopes were not selected or approved by Amazon. Solution Reapply for ...